topic/jsiwek/libmagic-integration

Description

This branch is in bro, 3rdparty, bromagic, bro-testing, and bro-testing-private repos. It integrates libmagic 5.16 into Bro as a CMake ExternalProject, which requires CMake >= 2.8.0, so that one does not have to install libmagic to build bro.

Resolves BIT-1111, BIT-1096.

Environment

None

Assignee

Unassigned

Reporter

Jon Siwek

Labels

None

External issue ID

None

Components

Fix versions

Priority

Normal
Configure