trace-summary should be updated to support newer versions of Python

Description

Some of the code in trace-summary is not valid syntax on
Python version >= 3. It should be updated to work on
any Python version >= 2.6.

Environment

None

Activity

Show:
Seth Hall
February 5, 2015, 5:53 PM

Do you already know the list of problems that need addressed? (probably not worth documenting?)

Daniel Thayer
February 5, 2015, 7:02 PM

All the work is done in branch topic/dnthayer/ticket1304. The one remaining task is
to get pysubnettree (which lives in a different git repo) compatible with Python 3.
Currently, trace-summary requires pysubnettree.

Seth Hall
February 5, 2015, 7:19 PM

Awesome thanks!

Assignee

Unassigned

Reporter

Daniel Thayer

Labels

None

External issue ID

None

Components

Fix versions

Priority

Normal
Configure