trace-summary should be updated to support newer versions of Python

Description

Some of the code in trace-summary is not valid syntax on
Python version >= 3. It should be updated to work on
any Python version >= 2.6.

Environment

None

Assignee

Unassigned

Reporter

Daniel Thayer

Labels

None

External issue ID

None

Components

Fix versions

Priority

Normal
Configure