Broctl installation requires sqlite but does not check for its presence

Description

Trying to start broctl on a new installation of FreeBSD with a standard python installation results in the following error message upon first start:

We should probably check for the module in cmake and refuse installation if it is not present.

Environment

None

Activity

Show:
Aashish Sharma
March 18, 2015, 6:46 PM

I am trying to test some stuff with the current master on FreeBSD.

Any idea when this would be fixed and/or any hints on a workaround ?

Thanks,

Daniel Thayer
March 18, 2015, 7:00 PM

On FreeBSD, you need to install a package called py27-sqlite3.

Aashish Sharma
March 18, 2015, 7:00 PM

installing py27-sqlite3 does fix the issue on 10.1-RELEASE-p5

Thanks!

Assignee

Jon Siwek

Reporter

Johanna Amann

Labels

None

External issue ID

None

Components

Fix versions

Affects versions

Priority

Normal
Configure