Put back the --help option to bro-cut

Description

bro-cut --help gives the error message:
bro-cut: illegal option – -

Environment

None

Activity

Show:
Justin Azoff
July 16, 2015, 5:37 PM

bro-cut needs to use getopt_long to add support for --help back in.

I see that bro ships with src/bsd-getopt-long.c for platforms that do not have it.. does anyone know the history behind this? I'm not sure if this should be imported into the bro-cut repository as well, or just assume that it is already present on all supported platforms.

in the meantime I will at least get the underlying issue fixed.

Justin Azoff
July 16, 2015, 5:55 PM

I pushed an initial fix for this to topic/jazoff/ticket1436

https://github.com/bro/bro-aux/commit/94dcc3723e677b62ff8706a8f40c28ddd7308638

Other than the bsd-getopt inclusion issue that should be all there is to it.

Robin Sommer
July 21, 2015, 4:38 PM

Using getopt_long shouldn't be a problem I'm guessing. I'll merge as is, and if no problems show up, I'll remove the custom code from Bro as well.

Merged

Assignee

Daniel Thayer

Reporter

Doris Schioberg

Labels

None

External issue ID

None

Components

Affects versions

Priority

Normal
Configure