'Make' failure during Building CXX objects X509.cc.o & OCSP.cc.o

Description

Running entire installation as root. Tried downloading source code package (v2.5.3) from downloads page, as well as git cloning- same result. 'Make' command gets to the [ 73%] Building CXX object src/file_analysis/analyzer/x509/CMakeFiles/plugin-Bro-X509.dir/X509.cc.o phase, then gives a few warnings:

/root/bro/src/file_analysis/analyzer/x509/X509.cc:293:37: warning: 'unsigned char* ASN1_STRING_data(ASN1_STRING*)' is deprecated [-Wdeprecated-declarations]
/root/bro/src/file_analysis/analyzer/x509/X509.cc:293:64: warning: 'unsigned char* ASN1_STRING_data(ASN1_STRING*)' is deprecated [-Wdeprecated-declarations]

On the next phase, [ 73%] Building CXX object src/file_analysis/analyzer/x509/CMakeFiles/plugin-Bro-X509.dir/OCSP.cc.o, the errors start occurring:

/root/bro/src/file_analysis/analyzer/x509/OCSP.cc:47:13: error: invalid use of incomplete type 'OCSP_RESPID {aka struct ocsp_responder_id_st}'

and so on for other variations of type 'OCSP_XXXXX'

Attached is the full output from my console.

I found BIT-1775, and it referenced Pull #118, which seems to indicate this issue was resolved ("Running this for 4 days has not shown any obvious issues; going to merge in a bit"), but it doesn't appear to be resolved.

I tried uninstalling openssl1.1 and installing openssl1.0, did not work (though to be fair, I'm not sure if I did this properly- apt list showed openssl1.1 still appeared to be installed somehow...). Regardless, the Git merge indicated Bro should support 1.1 now.

I know Raspbian isn't explicitly stated as a supported OS, but it's based on Debian, so that should be ok. Unless you are aware of any specific reasons why Bro wouldn't work on Raspbian.

Environment

OS = Raspbian 9 Stretch
HW = Raspberry Pi 3

Assignee

Unassigned

Reporter

Wills TechBlog

External issue ID

None

Components

Affects versions

Priority

Normal
Configure